Вероятно, даже лучше:
Decalre doSomeStuff()
как метод foo
и вызовите: f.doSomeStuff()
Это гораздо более читабельно и его легче поддерживать, делая этотак что, если у вас есть подкласс foo
: Bar
, и вы хотите вычислить вещи немного по-другому - все, что вам нужно сделать, это переопределить doSomeStuff()
в Bar
Вы должныпредпочитаю удобочитаемость, а не микрооптимизацию - пусть компилятор позаботится о них для вас.
привязка кода:
class foo() {
public int value;
public int doSomeStuff() {
return value + 1;
}
}
и:
public int doOtherStuff() {
...
foo f = new foo();
int x = f.doSomeStuff();
...
}